What’s Vulnerable › Vulnerabilities
CVE-2024-4994: Cross-Site Request Forgery (CSRF) in GitLab
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-20 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 16.1.0 before 16.11.5, all versions starting from 17.0 before 17.0.3, all versions starting from 17.1.0 before 17.1.1 which allowed for a CSRF attack on GitLab's GraphQL API leading to the execution of arbitrary GraphQL mutations.
Affected products
- GitLab: from 16.1.0 before 16.11.5; from 17.0.0 before 17.0.3; 17.1.0 — fixed in 16.11.5, 17.0.3
How to fix
Upgrade to a fixed version: GitLab 16.11.5, 17.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4994 or the next vulnerability affects your stack