What’s Vulnerable › Vulnerabilities
CVE-2024-49945: net/ncsi: Disable the ncsi work before freeing the associated structure
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-10-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: net/ncsi: Disable the ncsi work before freeing the associated structure The work function can run after the ncsi device is freed, resulting in use-after-free bugs or kernel panic.
Affected products
- Linux kernel: from 4.8 before 6.10.14; from 6.11 before 6.11.3; 6.12-rc1 — fixed in 6.10.14, 6.11.3
- Linux: 4.8 — fixed in 6.12
How to fix
Upgrade to a fixed version: Linux kernel 6.10.14, 6.11.3; Linux 6.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/64704f231d5dee8639e256507178f43dde1f131c
- https://git.kernel.org/stable/c/6a921089feeef364169a34a7e5a3968138c00c7f
- https://git.kernel.org/stable/c/a0ffa68c70b367358b2672cdab6fa5bc4c40de2c
- https://git.kernel.org/stable/c/dd41dab62f32d9e9e0669af8459d12a93834b238
- https://git.kernel.org/stable/c/f6ca58696749268181f43150b3553f2bafd71e42
Get alerted when CVE-2024-49945 or the next vulnerability affects your stack