What’s Vulnerable › Vulnerabilities
CVE-2024-49956: gfs2: fix double destroy_workqueue error
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-08-04
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: gfs2: fix double destroy_workqueue error When gfs2_fill_super() fails, destroy_workqueue() is called within gfs2_gl_hash_clear(), and the subsequent code path calls destroy_workqueue() on the same work queue again. This issue can be fixed by setting the work queue pointer to NULL after the first destroy_workqueue() call and checking for a NULL pointer before attempting to destroy the work queue again.
Affected products
- Linux kernel: from 6.11 before 6.11.3 — fixed in 6.11.3
How to fix
Upgrade to a fixed version: Linux kernel 6.11.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6cb9df81a2c462b89d2f9611009ab43ae8717841
- https://git.kernel.org/stable/c/a5336035728d77efd76306940d742a6f23debe68
Get alerted when CVE-2024-49956 or the next vulnerability affects your stack