What’s Vulnerable › Vulnerabilities
CVE-2024-5005: Incorrect Provision of Specified Functionality in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-684
Description
An issue has been discovered discovered in GitLab EE/CE affecting all versions starting from 11.4 before 17.2.9, all versions starting from 17.3 before 17.3.5, all versions starting from 17.4 before 17.4.2 It was possible for guest users to disclose project templates using the API.
Affected products
- GitLab: from 11.4.0 before 17.2.9; from 17.3.0 before 17.3.5; from 17.4.0 before 17.4.2 — fixed in 17.2.9, 17.3.5, 17.4.2
How to fix
Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5005 or the next vulnerability affects your stack