What’s Vulnerable › Vulnerabilities

CVE-2024-50052: Arbitrary post deletion via Playbooks /ignore-thread endpoint

Description

Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1, 9.5.x <= 9.5.9 fail to check that the origin of the message in an integration action matches with the original post metadata which allows an authenticated user to delete an arbitrary post.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 9.10.3, 9.11.2, 9.5.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-50052 or the next vulnerability affects your stack