What’s Vulnerable › Vulnerabilities
CVE-2024-5006: Boostify Header Footer Builder for Elementor <= 1.3.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via size Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Boostify Header Footer Builder for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘size’ parameter in all versions up to, and including, 1.3.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- duongancol Boostify Header Footer Builder for Elementor: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: duongancol Boostify Header Footer Builder for Elementor 1.3.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/boostify-header-footer-builder/trunk/inc/elementor/widgets/class-mega-menu-vertical.php#L393
- https://plugins.trac.wordpress.org/browser/boostify-header-footer-builder/trunk/inc/elementor/widgets/class-mega-menu.php#L525
- https://plugins.trac.wordpress.org/changeset/3097085/#file9
- https://wordpress.org/plugins/boostify-header-footer-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72c2a5d4-f201-4cc8-ac49-cde1160ca468?source=cve
- https://plugins.trac.wordpress.org/browser/boostify-header-footer-builder/trunk/inc/elementor/widgets/class-mega-menu-vertical.php#L393
- https://plugins.trac.wordpress.org/browser/boostify-header-footer-builder/trunk/inc/elementor/widgets/class-mega-menu.php#L525
- https://plugins.trac.wordpress.org/changeset/3097085/#file9
- https://wordpress.org/plugins/boostify-header-footer-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72c2a5d4-f201-4cc8-ac49-cde1160ca468?source=cve
Get alerted when CVE-2024-5006 or the next vulnerability affects your stack