What’s Vulnerable › Vulnerabilities
CVE-2024-50101: iommu/vt-d: Fix incorrect pci_for_each_dma_alias() for non-PCI devices
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: iommu/vt-d: Fix incorrect pci_for_each_dma_alias() for non-PCI devices Previously, the domain_context_clear() function incorrectly called pci_for_each_dma_alias() to set up context entries for non-PCI devices. This could lead to kernel hangs or other unexpected behavior. Add a check to only call pci_for_each_dma_alias() for PCI devices. For non-PCI devices, domain_context_clear_one() is called directly.
Affected products
- Linux kernel: from 5.15.142 before 5.15.169; from 5.16 before 6.1.114; from 6.2 before 6.6.58; from 6.7 before 6.11.5; 6.12-rc1, 6.12-rc2, 6.12-rc3 — fixed in 5.15.169, 6.1.114, 6.11.5, 6.6.58
How to fix
Upgrade to a fixed version: Linux kernel 5.15.169, 6.1.114, 6.11.5, 6.6.58. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/04d6826ba7ba81213422276e96c90c6565169e1c
- https://git.kernel.org/stable/c/0bd9a30c22afb5da203386b811ec31429d2caa78
- https://git.kernel.org/stable/c/6e02a277f1db24fa039e23783c8921c7b0e5b1b3
- https://git.kernel.org/stable/c/cbfa3a83eba05240ce37839ed48280a05e8e8f6c
- https://git.kernel.org/stable/c/fe2e0b6cd00abea3efac66de1da22d844364c1b0
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-50101 or the next vulnerability affects your stack