What’s Vulnerable › Vulnerabilities
CVE-2024-50129: net: pse-pd: Fix out of bound for loop
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: net: pse-pd: Fix out of bound for loop Adjust the loop limit to prevent out-of-bounds access when iterating over PI structures. The loop should not reach the index pcdev->nr_lines since we allocate exactly pcdev->nr_lines number of PI structures. This fix ensures proper bounds are maintained during iterations.
Affected products
- Linux kernel: from 6.10 before 6.11.6; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4 — fixed in 6.11.6
How to fix
Upgrade to a fixed version: Linux kernel 6.11.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/50ea68146d82f34b3ad80d8290ef8222136dedd7
- https://git.kernel.org/stable/c/f2767a41959e60763949c73ee180e40c686e807e
Get alerted when CVE-2024-50129 or the next vulnerability affects your stack