What’s Vulnerable › Vulnerabilities
CVE-2024-50180: fbdev: sisfb: Fix strbuf array overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: fbdev: sisfb: Fix strbuf array overflow The values of the variables xres and yres are placed in strbuf. These variables are obtained from strbuf1. The strbuf1 array contains digit characters and a space if the array contains non-digit characters. Then, when executing sprintf(strbuf, "%ux%ux8", xres, yres); more than 16 bytes will be written to strbuf. It is suggested to increase the size of the strbuf array to 24. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: before 4.19.323; from 4.20 before 5.4.285; from 5.5 before 5.10.227; from 5.11 before 5.15.168; from 5.16 before 6.1.113; from 6.2 before 6.6.57 — fixed in 4.19.323, 5.10.227, 5.15.168, 5.4.285, 6.1.113, 6.11.4
How to fix
Upgrade to a fixed version: Linux kernel 4.19.323, 5.10.227, 5.15.168, 5.4.285. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/11c0d49093b82f6c547fd419c41a982d26bdf5ef
- https://git.kernel.org/stable/c/252f147b1826cbb30ae0304cf86b66d3bb12b743
- https://git.kernel.org/stable/c/41cf6f26abe4f491b694c54bd1aa2530369b7510
- https://git.kernel.org/stable/c/433c84c8495008922534c5cafdae6ff970fb3241
- https://git.kernel.org/stable/c/57c4f4db0a194416da237fd09dad9527e00cb587
- https://git.kernel.org/stable/c/688872c4ea4a528cd6a057d545c83506b533ee1f
- https://git.kernel.org/stable/c/889304120ecb2ca30674d89cd4ef15990b6a571c
- https://git.kernel.org/stable/c/9cf14f5a2746c19455ce9cb44341b5527b5e19c3
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-50180 or the next vulnerability affects your stack