What’s Vulnerable › Vulnerabilities
CVE-2024-50185: mptcp: handle consistently DSS corruption
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: mptcp: handle consistently DSS corruption Bugged peer implementation can send corrupted DSS options, consistently hitting a few warning in the data path. Use DEBUG_NET assertions, to avoid the splat on some builds and handle consistently the error, dumping related MIBs and performing fallback and/or reset according to the subflow type.
Affected products
- Linux kernel: from 5.7 before 5.10.228; from 5.11 before 5.15.169; from 5.16 before 6.1.113; from 6.2 before 6.6.57; from 6.7 before 6.11.4; 6.12-rc1, 6.12-rc2 — fixed in 5.10.228, 5.15.169, 6.1.113, 6.11.4, 6.6.57
How to fix
Upgrade to a fixed version: Linux kernel 5.10.228, 5.15.169, 6.1.113, 6.11.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/12c1676d598e3b8dd92a033b623b792cc2ea1ec5
- https://git.kernel.org/stable/c/35668f8ec84f6c944676e48ecc6bbc5fc8e6fe25
- https://git.kernel.org/stable/c/8bfd391bde685df7289b928ce8876a3583be4bfb
- https://git.kernel.org/stable/c/b8be15d1ae7ea4eedd547c3b3141f592fbddcd30
- https://git.kernel.org/stable/c/e32d262c89e2b22cb0640223f953b548617ed8a6
- https://git.kernel.org/stable/c/fde99e972b8f88cebe619241d7aa43d288ef666a
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-50185 or the next vulnerability affects your stack