What’s Vulnerable › Vulnerabilities
CVE-2024-50208: RDMA/bnxt_re: Fix a bug while setting up Level-2 PBL pages
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/bnxt_re: Fix a bug while setting up Level-2 PBL pages Avoid memory corruption while setting up Level-2 PBL pages for the non MR resources when num_pages > 256K. There will be a single PDE page address (contiguous pages in the case of > PAGE_SIZE), but, current logic assumes multiple pages, leading to invalid memory access after 256K PBL entries in the PDE.
Affected products
- Linux kernel: from 5.7 before 5.10.229; from 5.11 before 5.15.170; from 5.16 before 6.1.115; from 6.2 before 6.6.59; from 6.7 before 6.11.6; 6.12-rc1, 6.12-rc2, 6.12-rc3 — fixed in 5.10.229, 5.15.170, 6.1.115, 6.11.6, 6.6.59
How to fix
Upgrade to a fixed version: Linux kernel 5.10.229, 5.15.170, 6.1.115, 6.11.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7988bdbbb85ac85a847baf09879edcd0f70521dc
- https://git.kernel.org/stable/c/87cb3b0054e53e0155b630bdf8fb714ded62565f
- https://git.kernel.org/stable/c/daac56dd98e1ba814c878ac0acd482a37f2ab94b
- https://git.kernel.org/stable/c/de5857fa7bcc9a496a914c7e21390be873109f26
- https://git.kernel.org/stable/c/df6fed0a2a1a5e57f033bca40dc316b18e0d0ce6
- https://git.kernel.org/stable/c/ea701c1849e7250ea41a4f7493e0a5f136c1d47e
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-50208 or the next vulnerability affects your stack