What’s Vulnerable › Vulnerabilities
CVE-2024-50218: ocfs2: pass u64 to ocfs2_truncate_inline maybe overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ocfs2: pass u64 to ocfs2_truncate_inline maybe overflow Syzbot reported a kernel BUG in ocfs2_truncate_inline. There are two reasons for this: first, the parameter value passed is greater than ocfs2_max_inline_data_with_xattr, second, the start and end parameters of ocfs2_truncate_inline are "unsigned int". So, we need to add a sanity check for byte_start and byte_len right before ocfs2_truncate_inline() in ocfs2_remove_inode_range(), if they are greater than ocfs2_max_inline_data_with_xattr return -EINVAL.
Affected products
- Linux kernel: from 2.6.24 before 4.19.323; from 4.20 before 5.4.285; from 5.5 before 5.10.229; from 5.11 before 5.15.171; from 5.16 before 6.1.116; from 6.2 before 6.6.60 — fixed in 4.19.323, 5.10.229, 5.15.171, 5.4.285, 6.1.116, 6.11.7
How to fix
Upgrade to a fixed version: Linux kernel 4.19.323, 5.10.229, 5.15.171, 5.4.285. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b6b8c2055784261de3fb641c5d0d63964318e8f
- https://git.kernel.org/stable/c/27d95867bee806cdc448d122bd99f1d8b0544035
- https://git.kernel.org/stable/c/2fe5d62e122b040ce7fc4d31aa7fa96ae328cefc
- https://git.kernel.org/stable/c/70767689ec6ee5f05fb0a2c17d7ec1927946e486
- https://git.kernel.org/stable/c/88f97a4b5843ce21c1286e082c02a5fb4d8eb473
- https://git.kernel.org/stable/c/95fbed8ae8c32c0977e6be1721c190d8fea23f2f
- https://git.kernel.org/stable/c/bc0a2f3a73fcdac651fca64df39306d1e5ebe3b0
- https://git.kernel.org/stable/c/ecd62f684386fa64f9c0cea92eea361f4e6444c2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-50218 or the next vulnerability affects your stack