What’s Vulnerable › Vulnerabilities
CVE-2024-50241: NFSD: Initialize struct nfsd4_copy earlier
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-08-04
- Weakness: CWE-908
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Initialize struct nfsd4_copy earlier Ensure the refcount and async_copies fields are initialized early. cleanup_async_copy() will reference these fields if an error occurs in nfsd4_copy(). If they are not correctly initialized, at the very least, a refcount underflow occurs.
Affected products
- Linux kernel: from 6.10.14 before 6.11.7; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5 — fixed in 6.11.7
How to fix
Upgrade to a fixed version: Linux kernel 6.11.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/059434d23c4578d9d02efb92d848ea21bc640112
- https://git.kernel.org/stable/c/421f1a2a1afb47d88de09457ef7687e1df7bc997
- https://git.kernel.org/stable/c/63fab04cbd0f96191b6e5beedc3b643b01c15889
- https://git.kernel.org/stable/c/7267625baf365a969f1b25ded6f07b64bc90ec5b
- https://git.kernel.org/stable/c/c3074003fa6837c2b89a34d8d12d9463b59d22d6
- https://git.kernel.org/stable/c/e30a9a2f69c34a00a3cb4fd45c5d231929e66fb1
Get alerted when CVE-2024-50241 or the next vulnerability affects your stack