What’s Vulnerable › Vulnerabilities
CVE-2024-50250: fsdax: dax_unshare_iter needs to copy entire blocks
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: fsdax: dax_unshare_iter needs to copy entire blocks The code that copies data from srcmap to iomap in dax_unshare_iter is very very broken, which bfoster's recent fsx changes have exposed. If the pos and len passed to dax_file_unshare are not aligned to an fsblock boundary, the iter pos and length in the _iter function will reflect this unalignment. dax_iomap_direct_access always returns a pointer to the start of the kmapped fsdax page, even if its pos argument is in the middle of that page. This is catastrophic for data integrity when iter->pos is not aligned to a page, because daddr/saddr do not point to the same byte in the file as iter->pos. Hence we corrupt user data by copying it to the wrong place. If iter->pos + iomap_length() in the _iter function not aligned to a page, then we fail to copy a full block, and only partially populate the destination block. This is catastrophic for data confidentiality because we expose stale pmem contents. Fix both of these issues by aligning copy_pos/copy_len to a page boundary (remember, this is fsdax so 1 fsblock == 1 base page) so that we always copy full blocks. We're not done yet -- there's no call to invalidate_inode_pages2_range, so programs that have the file range mmap'd will continue accessing the old memory mapping after the file metadata updates have completed. Be careful with the return value -- if the unshare succeeds, we still need to return the number of bytes that the iomap iter thinks we're operating on.
Affected products
- Linux kernel: from 6.1.113 before 6.1.116; from 6.2 before 6.6.60; from 6.7 before 6.11.7; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5 — fixed in 6.1.116, 6.11.7, 6.6.60
How to fix
Upgrade to a fixed version: Linux kernel 6.1.116, 6.11.7, 6.6.60. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/50793801fc7f6d08def48754fb0f0706b0cfc394
- https://git.kernel.org/stable/c/8e9c0f500b42216ef930f5c0d1703989a451913d
- https://git.kernel.org/stable/c/9bc18bb476e50e32e5d08f2734d63d63e0fa528c
- https://git.kernel.org/stable/c/bdbc96c23197d773a7d1bf03e4f11de593b0ff28
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-50250 or the next vulnerability affects your stack