What’s Vulnerable › Vulnerabilities
CVE-2024-50268: usb: typec: fix potential out of bounds in ucsi_ccg_update_set_new_cam_cmd()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: usb: typec: fix potential out of bounds in ucsi_ccg_update_set_new_cam_cmd() The "*cmd" variable can be controlled by the user via debugfs. That means "new_cam" can be as high as 255 while the size of the uc->updated[] array is UCSI_MAX_ALTMODES (30). The call tree is: ucsi_cmd() // val comes from simple_attr_write_xsigned() -> ucsi_send_command() -> ucsi_send_command_common() -> ucsi_run_command() // calls ucsi->ops->sync_control() -> ucsi_ccg_sync_control()
Affected products
- Linux kernel: from 5.6 before 5.10.230; from 5.11 before 5.15.172; from 5.16 before 6.1.117; from 6.2 before 6.6.61; from 6.7 before 6.11.8; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 — fixed in 5.10.230, 5.15.172, 6.1.117, 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 5.10.230, 5.15.172, 6.1.117, 6.11.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3a2ba841659a0f15102585120dea75d8d5209616
- https://git.kernel.org/stable/c/604314ecd682913925980dc955caea2d036eab5f
- https://git.kernel.org/stable/c/69e19774f15e12dda6c6c58001d059e30895009b
- https://git.kernel.org/stable/c/7dd08a0b4193087976db6b3ee7807de7e8316f96
- https://git.kernel.org/stable/c/8f47984b35f3be0cfc652c2ca358d5768ea3456b
- https://git.kernel.org/stable/c/d76923164705821aa1b01b8d9d1741f20c654ab4
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-50268 or the next vulnerability affects your stack