What’s Vulnerable › Vulnerabilities
CVE-2024-50283: ksmbd: fix slab-use-after-free in smb3_preauth_hash_rsp
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix slab-use-after-free in smb3_preauth_hash_rsp ksmbd_user_session_put should be called under smb3_preauth_hash_rsp(). It will avoid freeing session before calling smb3_preauth_hash_rsp().
Affected products
- Linux kernel: before 6.1.117; from 6.2 before 6.6.61; from 6.7 before 6.11.8; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 — fixed in 6.1.117, 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 6.1.117, 6.11.8, 6.6.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1b6ad475d4ed577d34e0157eb507be00c588bf5c
- https://git.kernel.org/stable/c/b8fc56fbca7482c1e5c0e3351c6ae78982e25ada
- https://git.kernel.org/stable/c/c6cdc08c25a868a08068dfc319fa9fce982b8e7f
- https://git.kernel.org/stable/c/cb645064e0811053c94e86677f2e58ed29359d62
- https://git.kernel.org/stable/c/f7557bbca40d4ca8bb1c6c940ac6c95078bd0827
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-50283 or the next vulnerability affects your stack