What’s Vulnerable › Vulnerabilities
CVE-2024-50284: ksmbd: Fix the missing xa_store error check
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-08-04
- Weakness: CWE-754
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: Fix the missing xa_store error check xa_store() can fail, it return xa_err(-EINVAL) if the entry cannot be stored in an XArray, or xa_err(-ENOMEM) if memory allocation failed, so check error for xa_store() to fix it.
Affected products
- Linux kernel: from 5.15.145 before 5.16; from 6.1.71 before 6.1.117; from 6.3 before 6.6.61; from 6.7 before 6.11.8; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 — fixed in 5.16, 6.1.117, 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 5.16, 6.1.117, 6.11.8, 6.6.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3abab905b14f4ba756d413f37f1fb02b708eee93
- https://git.kernel.org/stable/c/726c1568b9145fa13ee248df184b186c382a7ff8
- https://git.kernel.org/stable/c/c2a232c4f790f4bcd4d218904c56ac7a39a448f5
- https://git.kernel.org/stable/c/d8664ce789bd46290c59a00da6897252f92c237d
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-50284 or the next vulnerability affects your stack