What’s Vulnerable › Vulnerabilities
CVE-2024-50286: ksmbd: fix slab-use-after-free in ksmbd_smb2_session_create
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix slab-use-after-free in ksmbd_smb2_session_create There is a race condition between ksmbd_smb2_session_create and ksmbd_expire_session. This patch add missing sessions_table_lock while adding/deleting session from global session table.
Affected products
- Linux kernel: before 6.1.117; from 6.2 before 6.6.61; from 6.7 before 6.11.8; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 — fixed in 6.1.117, 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 6.1.117, 6.11.8, 6.6.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0a77715db22611df50b178374c51e2ba0d58866e
- https://git.kernel.org/stable/c/e7a2ad2044377853cf8c59528dac808a08a99c72
- https://git.kernel.org/stable/c/e923503a56b3385b64ae492e3225e4623f560c5b
- https://git.kernel.org/stable/c/f56446ba5378d19e31040b548a14ee9a8f1500ea
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-50286 or the next vulnerability affects your stack