What’s Vulnerable › Vulnerabilities
CVE-2024-50289: media: av7110: fix a spectre vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: media: av7110: fix a spectre vulnerability As warned by smatch: drivers/staging/media/av7110/av7110_ca.c:270 dvb_ca_ioctl() warn: potential spectre issue 'av7110->ci_slot' [w] (local cap) There is a spectre-related vulnerability at the code. Fix it.
Affected products
- Linux kernel: from 2.6.13 before 6.11.8; 2.6.12-rc2, 2.6.12-rc3, 2.6.12-rc4, 2.6.12-rc5, 6.12-rc1, 6.12-rc2 (+4); 2.6.12 — fixed in 6.11.8
- Linux: 2.6.12 — fixed in 6.12
How to fix
Upgrade to a fixed version: Linux kernel 6.11.8; Linux 6.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e58d7070eef16615e280d9b25d334b08e042b61
- https://git.kernel.org/stable/c/458ea1c0be991573ec436aa0afa23baacfae101a
- https://git.kernel.org/stable/c/8567e451158fc75b633c37a5b15bb40a954ec554
- https://git.kernel.org/stable/c/f3927206c478bd249c225414f7a751752a30e7b9
Get alerted when CVE-2024-50289 or the next vulnerability affects your stack