What’s Vulnerable › Vulnerabilities
CVE-2024-50300: regulator: rtq2208: Fix uninitialized use of regulator_config
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-08-04
- Weakness: CWE-908
Description
In the Linux kernel, the following vulnerability has been resolved: regulator: rtq2208: Fix uninitialized use of regulator_config Fix rtq2208 driver uninitialized use to cause kernel error.
Affected products
- Linux kernel: from 6.6 before 6.6.61; from 6.7 before 6.11.8; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 — fixed in 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 6.11.8, 6.6.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2feb023110843acce790e9089e72e9a9503d9fa5
- https://git.kernel.org/stable/c/64fbab934ae59be9caffc80a75450984b1e108e0
- https://git.kernel.org/stable/c/9b7c0405af667857b3ad24a7ef6723f5475a9e43
Get alerted when CVE-2024-50300 or the next vulnerability affects your stack