What’s Vulnerable › Vulnerabilities
CVE-2024-50306: Apache Traffic Server: Server process can fail to drop privilege
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-252
Description
Unchecked return value can allow Apache Traffic Server to retain privileges on startup. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.5, from 10.0.0 through 10.0.1. Users are recommended to upgrade to version 9.2.6 or 10.0.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Traffic Server: from 9.0.0 before 9.2.6; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 9.2.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.0.2, 9.2.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/y15fh6c7kyqvzm0f9odw7c5jh4r4np0y
- https://lists.debian.org/debian-lts-announce/2025/02/msg00018.html
Get alerted when CVE-2024-50306 or the next vulnerability affects your stack