What’s Vulnerable › Vulnerabilities
CVE-2024-50352: LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/device/overview/services.inc.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 41.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Services" section of the Device Overview page allows authenticated users to inject arbitrary JavaScript through the "name" parameter when adding a service to a device. This vulnerability could result in the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and enabling unauthorized actions. This vulnerability is fixed in 24.10.0.
Affected products
- librenms: before 24.10.0 — fixed in 24.10.0
How to fix
Upgrade to a fixed version: librenms 24.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/b4af778ca42c5839801f16ece53505bb7fa1e7bc
- https://github.com/librenms/librenms/security/advisories/GHSA-qr8f-5qqg-j3wg
Get alerted when CVE-2024-50352 or the next vulnerability affects your stack