What’s Vulnerable › Vulnerabilities
CVE-2024-50357
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-29 · updated 2026-06-17
- Weakness: CWE-684
Description
FutureNet NXR series routers provided by Century Systems Co., Ltd. have REST-APIs, which are configured as disabled in the initial (factory default) configuration. But, REST-APIs are unexpectedly enabled when the affected product is powered up, provided either http-server (GUI) or Web authentication is enabled. The factory default configuration makes http-server (GUI) enabled, which means REST-APIs are also enabled. The username and the password for REST-APIs are configured in the factory default configuration. As a result, an attacker may obtain and/or alter the affected product's settings via REST-APIs.
Affected products
- Centurysys Futurenet Nxr-G050 Firmware: from 21.12.5 before 21.12.11 — fixed in 21.12.11
- Centurysys Futurenet Nxr-G060 Firmware: before 21.15.6C1 — fixed in 21.15.6C1
- Centurysys Futurenet Nxr-G110 Firmware: from 21.15.7 before 21.15.9 — fixed in 21.15.9
How to fix
Upgrade to a fixed version: Centurysys Futurenet Nxr-G050 Firmware 21.12.11; Centurysys Futurenet Nxr-G060 Firmware 21.15.6C1; Centurysys Futurenet Nxr-G110 Firmware 21.15.9. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/vu/JVNVU95001899/
- https://www.centurysys.co.jp/backnumber/nxr_common/20241031-01.html
Get alerted when CVE-2024-50357 or the next vulnerability affects your stack