What’s Vulnerable › Vulnerabilities
CVE-2024-50416: WordPress WPC Shop as a Customer for WooCommerce plugin <= 1.2.6 - PHP Object Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in WPClever WPC Shop as a Customer for WooCommerce wpc-shop-as-customer allows Object Injection.This issue affects WPC Shop as a Customer for WooCommerce: from n/a through <= 1.2.6.
Affected products
- wpclever WPC Shop as a Customer for WooCommerce: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: wpclever WPC Shop as a Customer for WooCommerce 1.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50416 or the next vulnerability affects your stack