What’s Vulnerable › Vulnerabilities
CVE-2024-50437: WordPress GeoDirectory plugin <= 2.3.80 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Paolo GeoDirectory geodirectory allows Stored XSS.This issue affects GeoDirectory: from n/a through <= 2.3.80.
Affected products
- paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory: before 2.3.81 — fixed in 2.3.81
How to fix
Upgrade to a fixed version: paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory 2.3.81. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50437 or the next vulnerability affects your stack