What’s Vulnerable › Vulnerabilities
CVE-2024-50439: WordPress Astra Widgets plugin <= 1.2.14 - Stored Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Astra Widgets astra-widgets allows Stored XSS.This issue affects Astra Widgets: from n/a through <= 1.2.14.
Affected products
- Brainstorm Force Astra Widgets: before 1.2.15 — fixed in 1.2.15
How to fix
Upgrade to a fixed version: Brainstorm Force Astra Widgets 1.2.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50439 or the next vulnerability affects your stack