What’s Vulnerable › Vulnerabilities
CVE-2024-50440: WordPress CodePen Embedded Pens Shortcode plugin <= 1.0.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Chris Coyier CodePen Embedded Pens Shortcode codepen-embedded-pen-shortcode allows Stored XSS.This issue affects CodePen Embedded Pens Shortcode: from n/a through <= 1.0.2.
Affected products
- Chris Coyier CodePen Embedded Pens Shortcode: before 1.0.3 — fixed in 1.0.3
How to fix
Upgrade to a fixed version: Chris Coyier CodePen Embedded Pens Shortcode 1.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50440 or the next vulnerability affects your stack