What’s Vulnerable › Vulnerabilities
CVE-2024-50442: WordPress Royal Elementor Addons and Templates plugin <= 1.3.980 - XML External Entity (XXE) vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-611
Description
Improper Restriction of XML External Entity Reference vulnerability in WP Royal Royal Elementor Addons royal-elementor-addons allows XML Injection.This issue affects Royal Elementor Addons: from n/a through <= 1.3.980.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.3.981 — fixed in 1.3.981
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.981. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50442 or the next vulnerability affects your stack