What’s Vulnerable › Vulnerabilities
CVE-2024-50449: WordPress PDF Generator Addon for Elementor Page Builder plugin <= 1.7.4 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in RedefiningTheWeb PDF Generator Addon for Elementor Page Builder pdf-generator-addon-for-elementor-page-builder allows Stored XSS.This issue affects PDF Generator Addon for Elementor Page Builder: from n/a through <= 1.7.4.
Affected products
- RedefiningTheWeb PDF Generator Addon for Elementor Page Builder: before 1.7.5 — fixed in 1.7.5
How to fix
Upgrade to a fixed version: RedefiningTheWeb PDF Generator Addon for Elementor Page Builder 1.7.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50449 or the next vulnerability affects your stack