What’s Vulnerable › Vulnerabilities
CVE-2024-50458: WordPress Advanced Sermons plugin <= 3.4 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP CodeUs Advanced Sermons advanced-sermons allows Stored XSS.This issue affects Advanced Sermons: from n/a through <= 3.4.
Affected products
- WP Codeus Advanced Sermons: before 3.5 — fixed in 3.5
How to fix
Upgrade to a fixed version: WP Codeus Advanced Sermons 3.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50458 or the next vulnerability affects your stack