What’s Vulnerable › Vulnerabilities
CVE-2024-5053: Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder <= 5.1.18 - Missing Authorization to Authenticated (Subscriber+) Mailchimp Integration Modification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-01 · updated 2026-06-17
- Weakness: CWE-285
Description
The Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder plugin for WordPress is vulnerable to unauthorized Malichimp API key update due to an insufficient capability check on the verifyRequest function in all versions up to, and including, 5.1.18. This makes it possible for Form Managers with a Subscriber-level access and above to modify the Mailchimp API key used for integration. At the same time, missing Mailchimp API key validation allows the redirect of the integration requests to the attacker-controlled server.
Affected products
- techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder: before 5.1.19 — fixed in 5.1.19
How to fix
Upgrade to a fixed version: techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder 5.1.19. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fluentform/trunk/app/Http/Policies/FormPolicy.php#L17
- https://plugins.trac.wordpress.org/browser/fluentform/trunk/app/Http/Routes/api.php#L91
- https://plugins.trac.wordpress.org/browser/fluentform/trunk/app/Services/Integrations/MailChimp/MailChimp.php#L40
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8242e0f0-b9c5-46fe-b691-3275cd0f9a43?source=cve
Get alerted when CVE-2024-5053 or the next vulnerability affects your stack