What’s Vulnerable › Vulnerabilities
CVE-2024-50550: WordPress LiteSpeed Cache plugin <= 6.5.1 - Privilege Escalation vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-266
Description
Incorrect Privilege Assignment vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Privilege Escalation.This issue affects LiteSpeed Cache: from n/a through <= 6.5.1.
Affected products
- LiteSpeed Technologies LiteSpeed Cache: before 6.5.2 — fixed in 6.5.2
How to fix
Upgrade to a fixed version: LiteSpeed Technologies LiteSpeed Cache 6.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50550 or the next vulnerability affects your stack