What’s Vulnerable › Vulnerabilities
CVE-2024-50565
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-300
Description
A improper restriction of communication channel to intended endpoints vulnerability [CWE-923] in Fortinet FortiOS version 7.4.0 through 7.4.3, 7.2.0 through 7.2.7, 7.0.0 through 7.0.14, 6.4.0 through 6.4.15 and 6.2.0 through 6.2.16, Fortinet FortiProxy version 7.4.0 through 7.4.2, 7.2.0 through 7.2.9, 7.0.0 through 7.0.15 and 2.0.0 through 2.0.14, Fortinet FortiManager version 7.4.0 through 7.4.2, 7.2.0 through 7.2.4, 7.0.0 through 7.0.11, 6.4.0 through 6.4.14 and 6.2.0 through 6.2.13, Fortinet FortiAnalyzer version 7.4.0 through 7.4.2, 7.2.0 through 7.2.4, 7.0.0 through 7.0.11, 6.4.0 through 6.4.14 and 6.2.0 through 6.2.13, Fortinet FortiVoice version 7.0.0 through 7.0.2, 6.4.0 through 6.4.8 and 6.0.0 through 6.0.12 and Fortinet FortiWeb version 7.4.0 through 7.4.2, 7.2.0 through 7.2.10, 7.0.0 through 7.0.10 allows an unauthenticated attacker in a man-in-the-middle position to impersonate the management device (FortiCloud server or/and in certain conditions, FortiManager), via intercepting the FGFM authentication request between the management device and the managed device
Affected products
- Fortinet FortiAnalyzer: from 6.2.0 before 6.2.14; from 6.4.0 before 6.4.15; from 7.0.0 before 7.0.12; from 7.2.0 before 7.2.5; from 7.4.0 before 7.4.3 — fixed in 6.2.14, 6.4.15, 7.0.12, 7.2.5, 7.4.3
- Fortinet FortiManager: from 6.2.0 before 6.2.14; from 6.4.0 before 6.4.15; from 7.0.0 before 7.0.12; from 7.2.0 before 7.2.5; from 7.4.0 before 7.4.3 — fixed in 6.2.14, 6.4.15, 7.0.12, 7.2.5, 7.4.3
- Fortinet FortiOS (FortiGate): from 6.4.0 before 7.0.16; from 7.2.0 before 7.2.9; from 7.4.0 before 7.4.5 — fixed in 7.0.16, 7.2.9, 7.4.5
- Fortinet FortiProxy: from 2.0.0 before 7.0.16; from 7.2.0 before 7.2.10; from 7.4.0 before 7.4.3 — fixed in 7.0.16, 7.2.10, 7.4.3
- Fortinet FortiVoice: from 6.0.0 before 6.4.9; from 7.0.0 before 7.0.3 — fixed in 6.4.9, 7.0.3
- Fortinet FortiWeb: from 7.4.0 before 7.4.3 — fixed in 7.4.3
How to fix
Upgrade to a fixed version: Fortinet FortiAnalyzer 6.2.14, 6.4.15, 7.0.12, 7.2.5; Fortinet FortiManager 6.2.14, 6.4.15, 7.0.12, 7.2.5; Fortinet FortiOS (FortiGate) 7.0.16, 7.2.9, 7.4.5; Fortinet FortiProxy 7.0.16, 7.2.10, 7.4.3; Fortinet FortiVoice 6.4.9, 7.0.3; Fortinet FortiWeb 7.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50565 or the next vulnerability affects your stack