What’s Vulnerable › Vulnerabilities
CVE-2024-50603: Aviatrix Controllers OS Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-01-16
- EPSS: 98.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered in Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996. Due to the improper neutralization of special elements used in an OS command, an unauthenticated attacker is able to execute arbitrary code. Shell metacharacters can be sent to /v1/api in cloud_type for list_flightpath_destination_instances, or src_cloud_type for flightpath_connection_test.
Affected products
- Aviatrix Controller: before 7.1.4191; from 7.2 before 7.2.4996 — fixed in 7.1.4191, 7.2.4996
How to fix
Upgrade to a fixed version: Aviatrix Controller 7.1.4191, 7.2.4996. Check the vendor advisory for mitigations.
References
- https://docs.aviatrix.com/documentation/latest/network-security/index.html
- https://docs.aviatrix.com/documentation/latest/release-notices/psirt-advisories/psirt-advisories.html?expand=true#remote-code-execution-vulnerability-in-aviatrix-controllers
- https://www.securing.pl/en/cve-2024-50603-aviatrix-network-controller-command-injection-vulnerability/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-50603
Get alerted when CVE-2024-50603 or the next vulnerability affects your stack