What’s Vulnerable › Vulnerabilities
CVE-2024-50628
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-862
Description
An issue was discovered in the web services of Digi ConnectPort LTS before 1.4.12. It allows an attacker on the local area network to achieve unauthorized manipulation of resources, which may lead to remote code execution when combined with other issues.
Affected products
- Digi Connectport Lts Firmware: before 1.4.12 — fixed in 1.4.12
How to fix
Upgrade to a fixed version: Digi Connectport Lts Firmware 1.4.12. Check the vendor advisory for mitigations.
References
- https://www.digi.com/getattachment/Resources/Security/Alerts/Digi-ConnectPort-LTS-Firmware-Update/ConnectPort-LTS-KB.pdf
- https://www.digi.com/resources/documentation/digidocs/pdfs/90001001.pdf
- https://www.digi.com/resources/security
Get alerted when CVE-2024-50628 or the next vulnerability affects your stack