What’s Vulnerable › Vulnerabilities
CVE-2024-50630
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 24.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-19 · updated 2026-06-17
- Weakness: CWE-306
Description
Missing authentication for critical function vulnerability in the webapi component in Synology Drive Server before 3.0.4-12699, 3.2.1-23280, 3.5.0-26085 and 3.5.1-26102 allows remote attackers to obtain administrator credentials via unspecified vectors.
Affected products
- Synology Drive: before 3.0.4-12699; before 3.2.1-23280; before 3.5.0-26085; before 3.5.1-26102 — fixed in 3.0.4-12699, 3.2.1-23280, 3.5.0-26085, 3.5.1-26102
How to fix
Upgrade to a fixed version: Synology Drive 3.0.4-12699, 3.2.1-23280, 3.5.0-26085, 3.5.1-26102. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-50630 or the next vulnerability affects your stack