What’s Vulnerable › Vulnerabilities
CVE-2024-50705
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-352
Description
Unauthenticated reflected cross-site scripting (XSS) vulnerability in Uniguest Tripleplay before 24.2.1 allows remote attackers to execute arbitrary scripts via the page parameter.
Affected products
- Uniguest Tripleplay: before 24.1.2; 24.2 — fixed in 24.1.2
How to fix
Upgrade to a fixed version: Uniguest Tripleplay 24.1.2. Check the vendor advisory for mitigations.
References
- https://uniguest.com/cve-bulletins/
- https://uniguest.com/wp-content/uploads/2025/02/CVE-2024-50705-Vulnerability-Summary.pdf
Get alerted when CVE-2024-50705 or the next vulnerability affects your stack