What’s Vulnerable › Vulnerabilities
CVE-2024-5079: WP eMember < 10.6.7 - Unauthenticated Stored XSS via Member Registration
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-eMember WordPress plugin before 10.6.7 does not sanitise and escape some of the fields when members register, which allows unauthenticated users to perform Stored Cross-Site Scripting attacks
Affected products
- wp-eMember: before 10.6.7 — fixed in 10.6.7
How to fix
Upgrade to a fixed version: wp-eMember 10.6.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bdb5509e-80ab-4e47-83a4-9347796eec40/
- https://wpscan.com/vulnerability/bdb5509e-80ab-4e47-83a4-9347796eec40/
Get alerted when CVE-2024-5079 or the next vulnerability affects your stack