What’s Vulnerable › Vulnerabilities
CVE-2024-5081: WP eMember <= v10.7.0 - Stored XSS via CSRF
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-352
Description
The wp-eMember WordPress plugin before v10.7.0 does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make logged in admin add Stored XSS payloads via a CSRF attack
Affected products
- wp-eMember: before 10.7.0 — fixed in 10.7.0
How to fix
Upgrade to a fixed version: wp-eMember 10.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5081 or the next vulnerability affects your stack