What’s Vulnerable › Vulnerabilities
CVE-2024-51092
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-08 · updated 2026-10-27
- Weakness: CWE-78
Description
LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().
Affected products
- librenms: before 24.10.0 — fixed in 24.10.0
How to fix
Upgrade to a fixed version: librenms 24.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-x645-6pf9-xwxw
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/linux/http/librenms_authenticated_rce_cve_2024_51092.rb
- https://github.com/librenms/librenms/security/advisories/GHSA-x645-6pf9-xwxw
Get alerted when CVE-2024-51092 or the next vulnerability affects your stack