What’s Vulnerable › Vulnerabilities

CVE-2024-51139

Description

Buffer Overflow vulnerability in Vigor2620/LTE200 3.9.8.9 and earlier and Vigor2860/2925 3.9.8 and earlier and Vigor2862/2926 3.9.9.5 and earlier and Vigor2133/2762/2832 3.9.9 and earlier and Vigor165/166 4.2.7 and earlier and Vigor2135/2765/2766 4.4.5.1 and earlier and Vigor2865/2866/2927 4.4.5.3 and earlier and Vigor2962/3910 4.3.2.8/4.4.3.1 and earlier and Vigor3912 4.3.6.1 and earlier allows a remote attacker to execute arbitrary code via the CGI parser's handling of the "Content-Length" header of HTTP POST requests.

Affected products

How to fix

Upgrade to a fixed version: DrayTek Vigor1000B Firmware 4.4.3.2; DrayTek Vigor2133 Firmware 3.9.9.2; DrayTek Vigor2135 Firmware 4.4.5.5; DrayTek Vigor2620 Firmware 3.9.9.1; DrayTek Vigor2762 Firmware 3.9.9.2; DrayTek Vigor2763 Firmware 4.4.5.5; DrayTek Vigor2765 Firmware 4.4.5.5; DrayTek Vigor2766 Firmware 4.4.5.5; DrayTek Vigor2832 Firmware 3.9.9.2; DrayTek Vigor2860 Firmware 3.9.8.3; DrayTek Vigor2862 Firmware 3.9.9.8; DrayTek Vigor2865 Firmware 4.4.5.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-51139 or the next vulnerability affects your stack