What’s Vulnerable › Vulnerabilities
CVE-2024-5127: Improper Access Control in lunary-ai/lunary
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-862
Description
In lunary-ai/lunary versions 1.2.2 through 1.2.25, an improper access control vulnerability allows users on the Free plan to invite other members and assign them any role, including those intended for Paid and Enterprise plans only. This issue arises due to insufficient backend validation of roles and permissions, enabling unauthorized users to join a project and potentially exploit roles and permissions not intended for their use. The vulnerability specifically affects the Team feature, where the backend fails to validate whether a user has paid for a plan before allowing them to send invite links with any role assigned. This could lead to unauthorized access and manipulation of project settings or data.
Affected products
- lunary-ai/lunary: from 1.2.2 before 1.2.25 — fixed in 1.2.25
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.25. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/b7bd3a830a0f47ba07d0fd57bf78c4dd8a216297
- https://huntr.com/bounties/719a5db3-f943-4100-a660-011cadf1bb32
- https://github.com/lunary-ai/lunary/commit/b7bd3a830a0f47ba07d0fd57bf78c4dd8a216297
- https://huntr.com/bounties/719a5db3-f943-4100-a660-011cadf1bb32
Get alerted when CVE-2024-5127 or the next vulnerability affects your stack