What’s Vulnerable › Vulnerabilities
CVE-2024-5129: Privilege Escalation Vulnerability in lunary-ai/lunary
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-862
Description
A Privilege Escalation Vulnerability exists in lunary-ai/lunary version 1.2.2, where any user can delete any datasets due to missing authorization checks. The vulnerability is present in the dataset deletion functionality, where the application fails to verify if the user requesting the deletion has the appropriate permissions. This allows unauthorized users to send a DELETE request to the server and delete any dataset by specifying its ID. The issue is located in the datasets.delete function within the datasets index file.
Affected products
- lunary-ai/lunary: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776
- https://huntr.com/bounties/a6c0deb3-6a4c-4188-8aaa-9e6207f82f44
- https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776
- https://huntr.com/bounties/a6c0deb3-6a4c-4188-8aaa-9e6207f82f44
Get alerted when CVE-2024-5129 or the next vulnerability affects your stack