What’s Vulnerable › Vulnerabilities
CVE-2024-5131: Improper Access Control in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-639
Description
An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.
Affected products
- lunary-ai/lunary: before 1.2.25 — fixed in 1.2.25
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.25. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/ddfd497afd017a6946c582a1a806687fdac888bf
- https://huntr.com/bounties/52c129f2-114e-492f-aee8-32c78f75ac4f
- https://github.com/lunary-ai/lunary/commit/ddfd497afd017a6946c582a1a806687fdac888bf
- https://huntr.com/bounties/52c129f2-114e-492f-aee8-32c78f75ac4f
Get alerted when CVE-2024-5131 or the next vulnerability affects your stack