What’s Vulnerable › Vulnerabilities
CVE-2024-5138
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-20
Description
The snapctl component within snapd allows a confined snap to interact with the snapd daemon to take certain privileged actions on behalf of the snap. It was found that snapctl did not properly parse command-line arguments, allowing an unprivileged user to trigger an authorised action on behalf of the snap that would normally require administrator privileges to perform. This could possibly allow an unprivileged user to perform a denial of service or similar.
Affected products
- Canonical Ltd. snapd: from 2.51.6 before 2.63.1 — fixed in 2.63.1
How to fix
Upgrade to a fixed version: Canonical Ltd. snapd 2.63.1. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/snapd/+bug/2065077
- https://github.com/snapcore/snapd/commit/68ee9c6aa916ab87dbfd9a26030690f2cabf1e14
- https://github.com/snapcore/snapd/security/advisories/GHSA-p9v8-q5m4-pf46
- https://www.cve.org/CVERecord?id=CVE-2024-5138
- https://bugs.launchpad.net/snapd/+bug/2065077
- https://github.com/snapcore/snapd/commit/68ee9c6aa916ab87dbfd9a26030690f2cabf1e14
- https://github.com/snapcore/snapd/security/advisories/GHSA-p9v8-q5m4-pf46
- https://www.cve.org/CVERecord?id=CVE-2024-5138
Get alerted when CVE-2024-5138 or the next vulnerability affects your stack