What’s Vulnerable › Vulnerabilities
CVE-2024-5139: Cross-Site Scripting via Authentication Endpoint in Multiple WSO2 Products Enables UI Manipulation and Redirection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-79
Description
The Authentication Endpoint accepts user-supplied input without sufficient encoding, allowing for the injection of malicious JavaScript payloads. This vulnerability can be triggered by submitting crafted input to the Authentication Endpoint. Successful exploitation allows an attacker to redirect the user's browser to a malicious website, modify the web page's user interface, or extract sensitive information from the browser. However, due to the `httpOnly` flag on session-related cookies, session hijacking is not possible.
Affected products
- WSO2 API Manager: from 3.1.0 before 3.1.0.286; from 3.2.0 before 3.2.0.376; from 3.2.1 before 3.2.1.10; from 4.0.0 before 4.0.0.299; from 4.1.0 before 4.1.0.159; from 4.2.0 before 4.2.0.91 — fixed in 3.1.0.286, 3.2.0.376, 3.2.1.10, 4.0.0.299, 4.1.0.159, 4.2.0.91
- WSO2 Enterprise Integrator: from 6.6.0 before 6.6.0.204 — fixed in 6.6.0.204
- WSO2 Identity Server: from 5.10.0 before 5.10.0.310; from 6.0.0 before 6.0.0.212; from 6.1.0 before 6.1.0.195; from 7.0.0 before 7.0.0.64 — fixed in 5.10.0.310, 6.0.0.212, 6.1.0.195, 7.0.0.64
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.306 — fixed in 5.10.0.306
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.336 — fixed in 2.0.0.336
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.357 — fixed in 2.0.0.357
- WSO2 Carbon User Management UI: from 5.14.127 before 5.14.127.6; from 5.17.5 before 5.17.5.273; from 5.17.118 before 5.17.118.3; from 5.18.187 before 5.18.187.260; from 5.18.248 before 5.18.248.12; from 5.23.8 before 5.23.8.191 — fixed in 5.14.127.6, 5.17.5.273, 5.17.118.3, 5.18.187.260, 5.18.248.12, 5.23.8.191
How to fix
Upgrade to a fixed version: WSO2 API Manager 3.1.0.286, 3.2.0.376, 3.2.1.10, 4.0.0.299; WSO2 Enterprise Integrator 6.6.0.204; WSO2 Identity Server 5.10.0.310, 6.0.0.212, 6.1.0.195, 7.0.0.64; WSO2 Identity Server As Key Manager 5.10.0.306; WSO2 Open Banking Am 2.0.0.336; WSO2 Open Banking Iam 2.0.0.357; WSO2 Carbon User Management UI 5.14.127.6, 5.17.5.273, 5.17.118.3, 5.18.187.260. Check the vendor advisory for mitigations.
References
- https://github.com/wso2/carbon-identity-framework/pull/5740
- https://github.com/wso2/carbon-identity-framework/pull/5741
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2024-3382/
Get alerted when CVE-2024-5139 or the next vulnerability affects your stack