What’s Vulnerable › Vulnerabilities
CVE-2024-51457: IBM Robotic Process Automation for Cloud Pak cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Robotic Process Automation for Cloud Pak 21.0.0 through 21.0.7.19 and 23.0.0 through 23.0.19 is vulnerable to cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM Robotic Process Automation for Cloud Pak: from 21.0.0 before 21.0.7.20; from 23.0.0 before 23.0.20 — fixed in 21.0.7.20, 23.0.20
How to fix
Upgrade to a fixed version: IBM Robotic Process Automation for Cloud Pak 21.0.7.20, 23.0.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51457 or the next vulnerability affects your stack