What’s Vulnerable › Vulnerabilities
CVE-2024-51466: IBM Cognos Analytics expression language injection
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-917
Description
IBM Cognos Analytics 11.2.0 through 11.2.4 FP4 and 12.0.0 through 12.0.4 is vulnerable to an Expression Language (EL) Injection vulnerability. A remote attacker could exploit this vulnerability to expose sensitive information, consume memory resources, and/or cause the server to crash when using a specially crafted EL statement.
Affected products
- IBM Cognos Analytics: from 11.2.0 before 11.2.4; from 12.0.0 before 12.0.4; 11.2.4, 11.2.4-fixpack1, 11.2.4-fixpack2, 11.2.4-fixpack3, 11.2.4-fixpack4, 12.0.4 — fixed in 11.2.4, 12.0.4
How to fix
Upgrade to a fixed version: IBM Cognos Analytics 11.2.4, 12.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-51466 or the next vulnerability affects your stack