What’s Vulnerable › Vulnerabilities

CVE-2024-51470: IBM MQ denial of service

Description

IBM MQ 9.1 LTS, 9.2 LTS, 9.3 LTS, 9.3 CD, 9.4 LTS, 9.4 CD, IBM MQ Appliance 9.3 LTS, 9.3 CD, 9.4 LTS, and IBM MQ for HPE NonStop 8.1.0 through 8.1.0.25 could allow an authenticated user to cause a denial-of-service due to messages with improperly set values.

Affected products

How to fix

Upgrade to a fixed version: IBM MQ Appliance 9.1.0.26, 9.2.0.30, 9.3.0.26, 9.4.0.7; IBM MQ for HPE NonStop 8.1.0.26. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-51470 or the next vulnerability affects your stack