What’s Vulnerable › Vulnerabilities
CVE-2024-51479: Authorization bypass in Next.js
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-17 · updated 2026-06-17
- Weakness: CWE-285
Description
Next.js is a React framework for building full-stack web applications. In affected versions if a Next.js application is performing authorization in middleware based on pathname, it was possible for this authorization to be bypassed for pages directly under the application's root directory. For example: * [Not affected] `https://example.com/` * [Affected] `https://example.com/foo` * [Not affected] `https://example.com/foo/bar`. This issue is patched in Next.js `14.2.15` and later. If your Next.js application is hosted on Vercel, this vulnerability has been automatically mitigated, regardless of Next.js version. There are no official workarounds for this vulnerability.
Affected products
- Next.js: from 9.5.5 before 14.2.15 — fixed in 14.2.15
- Npm Next: from 9.5.5 before 14.2.15 — fixed in 14.2.15
How to fix
Upgrade to a fixed version: Next.js 14.2.15; Npm Next 14.2.15. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/releases/tag/v14.2.15
- https://github.com/vercel/next.js/security/advisories/GHSA-7gfc-8cq8-jh5f
Get alerted when CVE-2024-51479 or the next vulnerability affects your stack